Results 1 to 8 of 8

Thread: Warning: file_get_contents(.\./languages/lang_english.conf)

  1. #1
    New Pligger anibol's Avatar
    Joined
    Jul 2009
    Posts
    4

    Warning: file_get_contents(.\./languages/lang_english.conf)

    Hi, i've done a fresh installation, revised the files/directories permissions and i get this error:


    Warning: file_get_contents(.\./languages/lang_english.conf) [function.file-get-contents]: failed to open stream: No such file or directory in D:\inetpub\vhosts\tod-os.com\httpdocs\class.config.php on line 49
    Could not open .\./languages/lang_english.conf

    I think the problem is with .\./ of the file path. It's installed on Windows Server.

    Any idea??
    Thanks

  2. #2
    New Pligger anibol's Avatar
    Joined
    Jul 2009
    Posts
    4

    Solved error, now new error

    Hi, i've solved the first problem configuring settings.php that way:

    $my_pligg_base = './';

    Now i get this error:

    Warning: include(./libs/link_summary.php) [function.include]: failed to open stream: No such file or directory in D:\inetpub\vhosts\tod-os.com\httpdocs\index.php on line 105

    Let's see what's about

  3. #3
    Senior Member nellaitamil's Avatar
    Joined
    Dec 2008
    Posts
    208
    I think Your Not install in lang_english.conf file.

    Reput in lang_english.conf file of the languages folder.

  4. #4
    New Pligger anibol's Avatar
    Joined
    Jul 2009
    Posts
    4
    The file is in the folder and with correct permissions.

    My first solution break the css path on admin panel

  5. #5
    New Pligger anibol's Avatar
    Joined
    Jul 2009
    Posts
    4
    That's the situation
    1. If i configure $my_pligg_base to ''; I get this error:

    Warning: file_get_contents(.\./languages/lang_english.conf) [function.file-get-contents]: failed to open stream: No such file or directory in D:\inetpub\vhosts\tod-os.com\httpdocs\class.config.php on line 49
    Could not open .\./languages/lang_english.conf

    2. If i configure $my_pligg_base to './'; I get that the site doesn't form correctly the path to css files, etc. The site runs and i get a second error on index.php here:
    include('libs/link_summary.php'); // this is the code that show the links / stories

    So i remove ./ of the path and the site works but the admin panel doesn't get the correct path to css files

    <link rel="stylesheet" type="text/css" href=".//templates/admin/css/fraxi.css" media="screen">

    Any help??

  6. #6
    Pligg Founder/Coder/Designer Yankidank's Avatar
    Joined
    Dec 2005
    Location
    San Francisco, CA
    Posts
    5,538
    Make sure that in settings.php you have the correct settings for your website. Example below for if you installed pligg to http://sub.domain.com/folder/

    Code:
    $my_base_url = 'http://sub.domain.com';
    $my_pligg_base = '/folder';
    The Facebook Module for Pligg CMS!
    Register, Login, and Submit Stories with Facebook. An absolute MUST HAVE for all Pligg sites!

  7. #7
    Senior Member nellaitamil's Avatar
    Joined
    Dec 2008
    Posts
    208
    thanks Yankidank. am Change the settings.php.

  8. #8
    Junior Member baljeet_singh's Avatar
    Joined
    Mar 2013
    Posts
    1
    Hi ,

    I have fixed this problem. I was facing the same problem on my local system. I find many other users facing the same kind of problem "Could not open .\./languages/lang_english.conf " but I did not get any appropriate answer on pligg forum.

    I did research on pligg php code and find where it is causing the problem. I found problem in internal/class.config.php file, there is one function namely

    function config_load($file, $section_name = null, $var_name = null)

    $file argument is passing the incorrect file path like .\./languages/lang_english.conf. It should be

    $file = 'languages/lang_english.conf';

    I overwrite this $file variable or you can correct the file path from where config_load () is being called. After overwriting $file variable , It will not display any error.

    Please try my method to fix this problem. If anyone still facing the same problem then please let me know.

    Looking forward to hear your feedback soon.

    Best Regards
    Baljeet Singh

Similar Threads

  1. Only lang_english.conf on 1.0.0
    By trendscout in forum Questions & Comments
    Replies: 8
    Last Post: 06-17-2009, 02:52 PM
  2. Warning: file_get_contents(./../libs/lang.conf)
    By Thana in forum Questions & Comments
    Replies: 13
    Last Post: 10-21-2008, 12:56 PM
  3. Replies: 6
    Last Post: 07-24-2008, 07:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •