Results 1 to 8 of 8

Thread: [SOLVED] Admin link bug

  1. #1
    Senior Member peppolone's Avatar
    Joined
    Dec 2006
    Posts
    194

    [SOLVED] Admin link bug

    I installed versione 9beta(i tested also the svn), the admin links in urlmethod 2 don't work, the edit title go to www.mypliggsite.com/story/1/edit/ and the change status to .../story/1/modify/main/, and the edit comment go to /mycategory/mystory/edit.php?id=&commentid=1 (where is the id?).
    Sorry for my english!

  2. #2
    Pligg Developer/Admin kbeeveer46's Avatar
    Joined
    Jun 2006
    Posts
    3,215
    Yeah I know. I was actually working on URL method 2 stuff last night and it was 3 in the morning when I got to that page and was getting frustrated so I went to bed There's code in that same file for URL method 1 if you want to switch to that in the meantime.

  3. #3
    Senior Member peppolone's Avatar
    Joined
    Dec 2006
    Posts
    194
    Ty, but also with urlmethod1 the editcomment link is wrong, no id (edit.php?id=&commentid=1), i think there is a problem with var2.

  4. #4
    Pligg Developer/Admin kbeeveer46's Avatar
    Joined
    Jun 2006
    Posts
    3,215
    Are you using version 9? I just tested it and it works fine for me.

  5. #5
    Senior Member peppolone's Avatar
    Joined
    Dec 2006
    Posts
    194
    Yes version 9.

  6. #6
    New Pligger billyboylindien's Avatar
    Joined
    Sep 2007
    Posts
    4
    Yep, I've solved this bug.

    It's a ****ing feature of apache that you've to disable.

    In .htaccess:
    Code:
    ##### Re-directing Begin #####
    Options +Indexes +FollowSymlinks
    Become
    Code:
    ##### Re-directing Begin #####
    Options +Indexes +FollowSymlinks -Multiviews
    The multiviews mod have made me crazy.
    When you call for exemple: /story/9/edit/ it send you /story.php instead of using the rewrite folder.

    :finger: multiviews :blush:

  7. #7
    Constant Pligger Unknown's Avatar
    Joined
    Jul 2007
    Posts
    146
    Dude! This thread is from 2006, they're talking about version 9.0 beta! I think they fixed it in newer versions.

    But if you don't mind, can you expand more on what does multiviews do?

  8. #8
    New Pligger billyboylindien's Avatar
    Joined
    Sep 2007
    Posts
    4
    Quote Originally Posted by Unknown View Post
    Dude! This thread is from 2006, they're talking about version 9.0 beta! I think they fixed it in newer versions.

    But if you don't mind, can you expand more on what does multiviews do?

    No, not fixed in the 9.9

    Apache Content Negotiation
    Beware of Apache's Multiviews

Similar Threads

  1. [SOLVED] Published a story using admin section
    By twola in forum Questions & Comments
    Replies: 2
    Last Post: 01-04-2009, 05:58 PM
  2. [SOLVED] can't edit config in admin area
    By mike34z in forum Questions & Comments
    Replies: 4
    Last Post: 08-24-2007, 10:33 PM
  3. 9.7 admin error - any admin link clicked just refreshes the page?
    By Exertrack in forum Questions & Comments
    Replies: 0
    Last Post: 07-17-2007, 01:03 PM
  4. [SOLVED] Change god to admin
    By BobdeBilder in forum Questions & Comments
    Replies: 5
    Last Post: 07-03-2007, 07:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •