Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Ban URL Bug

  1. #1
    Pligg Donor Iceburg's Avatar
    Joined
    Sep 2006
    Posts
    85

    Ban URL Bug

    I have the Ban URL up and working and its been great... but I continue to get spammed. For example

    listing banned domains

    www.somespamsite.com
    www.greathealthinformation.com
    custom-writing.org
    custom-writing.org
    www.greathealthservices.com
    custom-writing.org
    www.greathealthservices.com
    custom-writing.org
    www.love-shop.biz
    www.love-shop.biz
    custom-writing.org
    custom-writing.org
    custom-writing.org
    (etc, etc, etc, etc)


    You can see that these custom-writing.org bastards are submitted articles to the site, and its annoying me. I can ban all the URLs but all they need to do is to change one thing:

    http://www.spammer.com/bastards.htm
    http://www.spammer.com/bastards1.htm

    and its a new URL and its allowed to submit. Can I ban a domain?

  2. #2
    Mayor of PliggVille/Coder AshDigg's Avatar
    Joined
    Dec 2005
    Posts
    1,515
    Did you set 'Enable spam checking' to TRUE in your admin panel and are these sites in your anti-spam.txt file? What pligg version are you using?

  3. #3
    Pligg Donor Iceburg's Avatar
    Joined
    Sep 2006
    Posts
    85
    Yes, in the anti-spam file, here are my settings:



    description: Checks submitted domains to see if they're on a blacklist.
    value: true
    default value: false
    expected values: true / false
    Main spam ruleset
    description: Main spam ruleset
    value: antispam.txt
    default value: antispam.txt
    expected values: text file
    User Spam Ruleset
    description: User Spam Ruleset
    value: local-antispam.txt
    default value: local-antispam.txt
    expected values: text file
    Spam log
    description: File to log all spam blocks into.
    value: spamlog.log
    default value: spamlog.log
    expected values: text file

    Local-antispam:
    Code:
    www.somespamsite.com
    www.greathealthinformation.com
    custom-writing.org
    custom-writing.org
    www.greathealthservices.com
    custom-writing.org
    www.greathealthservices.com
    custom-writing.org
    www.love-shop.biz
    www.love-shop.biz
    custom-writing.org
    custom-writing.org
    custom-writing.org
    custom-writing.org
    antispam.txt is blank.

  4. #4
    Pligg Donor Iceburg's Avatar
    Joined
    Sep 2006
    Posts
    85
    I just added the spammer to the antispam.txt and it made no difference if I try and submit an article from their site.

  5. #5
    Pligg Donor Iceburg's Avatar
    Joined
    Sep 2006
    Posts
    85
    Ash, anyone? Have a good answer?

  6. #6
    Pligg Donor Iceburg's Avatar
    Joined
    Sep 2006
    Posts
    85
    Still doesn't work, and I am still getting spam.... help?

  7. #7
    Mayor of PliggVille/Coder AshDigg's Avatar
    Joined
    Dec 2005
    Posts
    1,515
    Sorry for the delay. I did some testing on your site and figured out the problem. I'll have a fix for you tomorrow. Thanks.

  8. #8
    Pligg Donor Iceburg's Avatar
    Joined
    Sep 2006
    Posts
    85
    No problem Ash, let me know what you find, and the best way to resolve.

    -Nick

  9. #9
    Pligg Donor Iceburg's Avatar
    Joined
    Sep 2006
    Posts
    85
    The fix at:
    http://svn.sourceforge.net/viewvc/pl...8&pathrev=1049

    almost works.

    I get:

    URL is invalid or blocked: (http://custom-writing.org)

    try again



    but... I also see:


    Warning: fopen(spamlog.log) [function.fopen]: failed to open stream: Permission denied in /home/ftb/public_html/libs/link.php on line 797

    Warning: fwrite(): supplied argument is not a valid stream resource in /home/ftb/public_html/libs/link.php on line 798

    Warning: fclose(): supplied argument is not a valid stream resource in /home/ftb/public_html/libs/link.php on line 799

    I even gave full RWX permissions to all on the local-antispam.txt file

  10. #10
    New Pligger jager's Avatar
    Joined
    Feb 2007
    Posts
    3
    Hi, I've the same problem of Iceburg.
    the spam rules are actived and I put the spam URL in the two antispam file (antispam.txt e local-antispam.txt)...
    now if I try to insert a news from one o the banned sites the system publish the news. the log file si blank.

    what's wrong!?

    this is my pligg clone website:
    Insonni / Notizie pubblicate

    thanks

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •