Results 1 to 10 of 10

Thread: Problem with Upgrading from Pligg beta 9.0 to 9.5

  1. #1
    New Pligger rhythm's Avatar
    Joined
    Nov 2006
    Posts
    29

    Unhappy Problem with Upgrading from Pligg beta 9.0 to 9.5

    I had Pligg beta 9.0 installed (I did not upgrade to Pligg beta 9.1).

    Before upgrading to Pligg beta 9.5, I deleted all Pligg beta 9.0 files except the avatars and backup folder.

    I then uploaded the Pligg beta 9.5 files and filled the dbconnect.php file with the necessary details.

    I then ran the upgrade.php file, but I got this error

    This will upgrade the database for Pligg Beta v9.0 and above to the latest version.

    Note: this is just a database upgrade, you still need to upload the new files.

    Warning: Access denied for user 'pliggdemo'@'278.57.158.0/255.255.152.0' to database 'pliggdb' in /home/.margarida/rhythm/domainname.com/libs/db.php on line 129

    Warning: No database selected in /home/.margarida/rhythm/domainname.com/libs/db.php on line 206
    Error. The pligg_config table is empty or does not exist
    What could be causing this error?

  2. #2
    New Pligger jordanX's Avatar
    Joined
    May 2007
    Posts
    2
    Looks like database configuration is incorrect.

  3. #3
    New Pligger rhythm's Avatar
    Joined
    Nov 2006
    Posts
    29
    jordanX- Thanks for replying. But the database configuration is correct. I have put it correctly in dbconnect.php, do I have to put it anywhere else?

    Plz help.

  4. #4
    Pligg Donor beatniak's Avatar
    Joined
    Apr 2006
    Posts
    197
    it says: " Warning: Access denied" >>> I guess you filled in the wrong username / password for the database in the upgrade page.

    But always backup your database before upgrading! after the backup, try upgrading again with the right username/password.

  5. #5
    Banned Geoserv's Avatar
    Joined
    Feb 2007
    Posts
    796
    Check the oart in red, seems odd to me.

    /home/.margarida/rhythm/domainname.com/libs/db.php
    Geoserv

  6. #6
    Constant Pligger aaronpais's Avatar
    Joined
    Apr 2007
    Posts
    168
    Did you change 'settings.php' in your home folder before doing the upgrade?

  7. #7
    New Pligger rhythm's Avatar
    Joined
    Nov 2006
    Posts
    29
    Thanks for replying guys. The problem was because I had mispelt my database name.

    I would like to restore my database now (I had taken backup earlier) but I am confused as there are 2 files:

    MySQL-Data-Backup-pliggdemo-2007-05-08 20-24-45.sql
    MySQL-Structure-Backup-pliggdemo-2007-05-08 20-24-47.sql

    How can I restore my Database and which of these files can I use ? (I use DreamHost)

    Plz help this noob.

  8. #8
    Pligg Developer/Admin kbeeveer46's Avatar
    Joined
    Jun 2006
    Posts
    3,215
    If you only did an upgrade your database should still be there and you don't have to restore your backup. The upgrade process doesn't delete anything in your database.

  9. #9
    New Pligger rhythm's Avatar
    Joined
    Nov 2006
    Posts
    29
    No, i could not upgrade, it said that my config table was missing, so i installed the latest pligg over the existing DB, just to test out the new version.

    Now I want to restore my DB. I have the backups, but there are 2, so i am confused. How do i restore?

  10. #10
    Pligg Developer/Admin kbeeveer46's Avatar
    Joined
    Jun 2006
    Posts
    3,215
    using phpmyadmin, open your database and click on the sql tab at the top. Copy and paste the structure back up file and click on go. After you import that you do the same for the data backup file.

Similar Threads

  1. Opinions sought re: Upgrading from Pligg Beta 8 (circa 2006)
    By NeverHome in forum Questions & Comments
    Replies: 21
    Last Post: 11-17-2010, 12:36 PM
  2. Upgrading Pligg 6+ to Beta 7 default template not showing
    By Thana in forum Questions & Comments
    Replies: 1
    Last Post: 10-19-2008, 08:01 AM
  3. Problems Upgrading Beta 8 To 9.8
    By Prophet Tenebrae in forum Questions & Comments
    Replies: 2
    Last Post: 11-26-2007, 10:51 PM
  4. Errors after upgrading to beta 8
    By Noodles in forum Questions & Comments
    Replies: 2
    Last Post: 11-29-2006, 02:49 AM
  5. Issues upgrading to beta 8
    By confusion in forum Questions & Comments
    Replies: 2
    Last Post: 10-08-2006, 11:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •